Top
Phpuniverset logo
 

INDHOLD

Forside

Script libary

Job annoncer

Tips og Tricks

Konkurrence

Downloads

Dokumenter

PHP bog shop

Forum

Online udviklere


ARTIKLER

CSS

Diverse

E-handel / annoncer

Grafik

Html

Internet

Javascript

Linux

PHP/MySQL

Programmer

Flash

Søgemaskiner

Windows

C / C++


INFO

Information

Annoncering

Kontakt

Forside Forum PHP, mysql der bliver ikke vist noget billede på siden

der bliver ikke vist noget billede på siden


 

der bliver ikke vist noget billede på siden

tage jørgensen  

Hej 

Jeg har byggetet CMS hvor man kan uploade tekster, billeder, oprette og slette
menupunkter.

Alt funger på nær det med billederne.

Når jeg laver koden til at undersøge feltet billeder, og ved positivt resultat skal næste
kodelinje skrive en IMG-kode.

Der sker blot det at ved sidevisningen i browseren kommer de blot et lille icon som viser
at der er et billede, men viser ikke billedet.

I mysql ligger oplysnigerne om billedet som det skal.

Er det min kode der er forkert eller er det mig der er galt på den?

herr er koden:

<tr>
  <td><?php
 
if ($row_rsSideindhold['billede']) {
 echo 
'<img scr="billeder/'.
$row_rsSideindhold['billede'].'">';} ?>

  </td>
</tr>



Dato : 18.01.2007, 20:58

Visninger : 1275

Points : 60

 

når du ser egenskaber på billedet som ikke kan findes, hvad ser du? ser du et billede navn
eller bare billeder/


Dato : 18.01.2007, 23:16

Kommentar af : Thor B.N.  

 

 jeg ser dette. Parantes og slahs skal ilustrer det "icon" som bliver vist, men ingen navn
fælger med. 

 

Forsidens overskrift.  

Denne tekst vises på forsiden 
[/]
Dette er anden del af teksten på forsiden 
 


Dato : 18.01.2007, 23:48

Kommentar af : tage jørgensen  

 

 jeg ser dette. Parantes og slahs skal ilustrer det "icon" som bliver vist, men ingen navn
fælger med. 

 

Forsidens overskrift.  

Denne tekst vises på forsiden 
[/]
Dette er anden del af teksten på forsiden 
 


Dato : 19.01.2007, 00:14

skrevet af : Gæst  

 

her er et link til en side, hvor jeg har lagt linket op, de andre er døde links indtil
videre


Dato : 19.01.2007, 00:25

Kommentar af : tage jørgensen  

 

nå, men her er linket så:


http://www.thammawat.com/


Dato : 19.01.2007, 00:26

Kommentar af : tage jørgensen  

 

Hjælper det hvs du også kan se hvad jeg har iu recordset'et for sideindholdBillede, så er
det her:

<?php echo $row_rsSideindhold['billede']; ?>

denne stren bliver så modificeret til:

 if ($row_rsSideindhold['billede']) {
 echo '<img scr="billeder/'.$row_rsSideindhold['billede'].'">';} ?>

Håber dette giver gennembrudet :)


Dato : 20.01.2007, 12:33

Kommentar af : tage jørgensen  

 

du må ikke have mellemrum i dine billede fil navne

Dato : 20.01.2007, 20:37

Godkendt svar af : Thor B.N.  

 

Jeg må jo kravle på skafottet!!!

Det var en fejl fra min side ThoB.N. undskylder mange gange.

Problemet var, at der i databasen ikke blev indat img.*** i billedfeltet.
Dette problem løste jeg ved at skrive det ind manuelt i db.

Har nu ændret mine sider til at bruget recordsettet til at indsætte navnet ved hjælp af
Dynamic listmenu, hvor jeg opretter en rulleliste, hvor man så kan vælge billedet,
hvorefter det bliver sat ind i db.

But anyway jeg har da lært en del af dit idslag, især det første med While løkken.

Igen STOR TAK til ThorB.N:


Dato : 21.01.2007, 13:18

Afvist svar af : tage jørgensen  




Login for at skrive et indlæg :



   Brugernavn

Password
 

+ Opret en ny Bruger, Klik her

+ Glemt brugernavn/password

 

Send Artikel/anmeldelse til: phpuni@phpuniverset.dk

Tilbage til oversigt

© Copyright 2000 Propelcom Phpuniverset's politik om personlige oplysninger, artikler & Koder Phpuniverset er optimeret til Mozilla 1024 * 768 Phpuniverset version: 3.0 beta
Webhost : Ignesco.dk

Bund